<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" />
	<link rel="pingback" href="https://stlouis.cbslocal.com/xmlrpc.php" />

<!-- WP Header - Start -->
<meta name="news_keywords" content="afc west picks, jets chargers picks, dolphins broncos picks, chiefs raiders picks, jaime maggio interview" />
<meta name="keywords" content="afc west picks, jets chargers picks, dolphins broncos picks, chiefs raiders picks, jaime maggio interview" />
<meta property="fb:pages" content="74181625900" />
<title>NFL Week 11 AFC West Picks: &#8216;No Chance That The Jets Get A Win Against The Chargers,&#8217; Says CBS LA&#8217;s Jaime Maggio &#8211; CBS St. Louis</title>
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<link rel="dns-prefetch" href="//cdn.cookielaw.org" />
<script type="text/javascript" charset="UTF-8" src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="7547764e-53b9-4fff-aef7-ce9cb429c721"></script>
<link rel="dns-prefetch" href="//production-cmp.isgprivacy.cbsi.com" />
<script type="text/javascript" charset="UTF-8" src="https://production-cmp.isgprivacy.cbsi.com/dist/optanon-v1.1.0.js"></script>
<script type="text/javascript">!function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();</script>
<link rel='dns-prefetch' href='//w3.cdn.anvato.net' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//wayne.cbslocal.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="CBS St. Louis &raquo; Feed" href="https://stlouis.cbslocal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="CBS St. Louis &raquo; Comments Feed" href="https://stlouis.cbslocal.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="CBS St. Louis &raquo; NFL Week 11 AFC West Picks: &#8216;No Chance That The Jets Get A Win Against The Chargers,&#8217; Says CBS LA&#8217;s Jaime Maggio Comments Feed" href="https://stlouis.cbslocal.com/2020/11/19/nfl-week-11-afc-west-picks-chargers-broncos-chiefs-raiders/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://stlouis.cbslocal.com/_static/??-eJytj0sOwjAMRC9EsKpCBQvEWfIxJapjR/mI6xNSNqygEivbY7/RGB5RWeGCXKDcMWAGa7IisZrAs6XqXlLOcBMpmPat3cFPEAaDbmVjQhLtvsOR6uw5QxBXqW3026DV7XA/UEGznjF1mw9FtZBLkbjhpdWjBsPakyLPy/9TIbWJS//3Gi7D8TSM0+E8Tk91np9f' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-lato-font-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://stlouis.cbslocal.com/_static/??-eJyNy0sKgDAMANELWaNiKy7Es9QYVEg/kIh4e+0FxO3wBq5sMEWlqKA7BRLARQwn9AyiN1ONIhV8sSMin2tJIpD9RkYpZPb64y0L8RujStFzmFo79M3YWeceIdg5IQ==' type='text/css' media='all' />
<link rel='stylesheet' id='cbs-custom-css-css'  href='https://wayne.cbslocal.com/cbs-local-custom-css/global/cbslocal_custom_global.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-6' href='https://stlouis.cbslocal.com/_static/??-eJy1kt1uwyAMhV9ohDZqJu1i2rM44KWs5kfgNMrbz0mWVl2kqbnYBZJtfD4OBj0kZWJgDKz5jB6LNm1RFA2QTtR3LhTto+1JduYG5SFAh1mbIpUx4amS6EX/BXLBUG+nkmgGZ1Ex+kTAWHaKE2R+QvPbeTnHzCaulHu643j0LdpFP4eKXGFlgIFit/MacgtnCNV1O7zVuiyGLoNXn4h2sd2qe7VWdeVduOkf+Fas6VYOvojLNkMedeGR8EHx9PTkxTrk2+tN8X7I9vN4yJcJu/SbSDH/AzdeMQ/ZMW7Qvlcr7As5gQzrrTrOiJ98knz49+ProTnUTVPX32FJMPM=' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script type='text/javascript' src='https://stlouis.cbslocal.com/_static/??-eJydT0ESwiAM/JA0lRm8Ob4FKa1gCNhAnf5e7HiwJ1tPO9lkd7PwTMJEypYy5JsNlsFcWWA0GsGRwdJVyjOkiHPvEJvgqPF8gK1Cv0mRsAyOGELsCtaN7hZxBTHJb4eV9aPYcf7A7ojlQARNerDj225FiJpxzzHt6toXMtlF4r86/3jIYp0oc/W9hPPx1KpWKiWlfwF8yKe5'></script>
<script src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js?ver=5.5.2' id='partner__video__anvato-js'></script>
<script type='text/javascript' src='https://stlouis.cbslocal.com/_static/??-eJyFjcEOwjAMQ3+ILWwSQxwQ39KlUZcqbSeSst+nQrvswm6W/WzDtnZYslE2sIUSKeCsnRR0ApxRqm9WVHB+IeUP9YlzH/UC/4qND1JmJ6fk4eJtjEKnnVVq4KyQiq/Sko19IPtN7LJNvNJzuD2G6zjdpzF+AQq4VNE='></script>
<link rel="https://api.w.org/" href="https://stlouis.cbslocal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://stlouis.cbslocal.com/wp-json/wp/v2/posts/596094" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://stlouis.cbslocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://stlouis.cbslocal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.2" />
<link rel='shortlink' href='https://cbsloc.al/2UKd5Au' />
<link rel="alternate" type="application/json+oembed" href="https://stlouis.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fstlouis.cbslocal.com%2F2020%2F11%2F19%2Fnfl-week-11-afc-west-picks-chargers-broncos-chiefs-raiders%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://stlouis.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fstlouis.cbslocal.com%2F2020%2F11%2F19%2Fnfl-week-11-afc-west-picks-chargers-broncos-chiefs-raiders%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
<meta property="og:title" content="NFL Week 11 AFC West Picks: &#039;No Chance That The Jets Get A Win Against The Chargers,&#039; Says CBS LA&#039;s Jaime Maggio" /><meta property="og:image" content="https://stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2020/11/justin-herbert-chargers-1.jpg?w=1200" /><meta property="og:image:secure_url" content="https://stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2020/11/justin-herbert-chargers-1.jpg?w=1200" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="675" /><meta property="og:description" content="CBS Los Angeles sports anchor Jaime Maggio looks at AFC West matchups, as the Chargers look to down the Jets, and the Chiefs seek to avenge their loss to the Raiders." /><meta property="og:type" content="article" /><meta property="og:url" content="https://stlouis.cbslocal.com/2020/11/19/nfl-week-11-afc-west-picks-chargers-broncos-chiefs-raiders/" /><meta property="article:published_time" content="2020-11-19T15:12:41+00:00" /><meta property="article:suggested-social-copy" content="CBS Los Angeles sports anchor Jaime Maggio looks at AFC West matchups, as the Chargers look to down the Jets, and the Chiefs seek to avenge their loss to the Raiders." /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta property="og:category" content="Sports" />
<link rel="canonical" href="https://losangeles.cbslocal.com/2020/11/19/nfl-week-11-afc-west-picks-chargers-broncos-chiefs-raiders/" />
				<style>
					.main-story-wrapper .basicsection { margin-bottom: 20px; }
					.main-story-wrapper .basicsection span strong { display: block; font-size: 18px; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection img { float: none !important; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection br { margin-bottom: 5px; }
				</style>
			<link rel="amphtml" href="https://stlouis.cbslocal.com/2020/11/19/nfl-week-11-afc-west-picks-chargers-broncos-chiefs-raiders/amp/">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","publisher":{"@context":"http:\/\/schema.org","@type":"NewsMediaOrganization","@id":"https:\/\/stlouis.cbslocal.com","url":"https:\/\/stlouis.cbslocal.com","name":"CBS St. Louis","foundingDate":"1941-07-01T14:30:00+00:00","logo":{"@type":"ImageObject","url":"https:\/\/stlouis.cbslocal.com\/wp-content\/uploads\/sites\/15909850\/2018\/07\/2_cbs_stlouis.png?w=216"}},"url":"https:\/\/stlouis.cbslocal.com\/2020\/11\/19\/nfl-week-11-afc-west-picks-chargers-broncos-chiefs-raiders\/","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/stlouis.cbslocal.com\/2020\/11\/19\/nfl-week-11-afc-west-picks-chargers-broncos-chiefs-raiders\/"},"headline":"NFL Week 11 AFC West Picks: &#8216;No Chance That The Jets Get A Win Against The Chargers,&#8217; Says CBS LA&#8217;s Jaime Maggio","description":"CBS Los Angeles sports anchor Jaime Maggio looks at AFC West matchups, as the Chargers look to down the Jets, and the Chiefs seek to avenge their loss to the Raiders.","image":"https:\/\/stlouis.cbslocal.com\/wp-content\/uploads\/sites\/15909850\/2020\/11\/justin-herbert-chargers-1.jpg?w=150&#038;h=150&#038;crop=1","keywords":["Sports","AFC West","Denver Broncos","Jaime Maggio","Kansas City Chiefs","Las Vegas Raiders","Los Angeles Chargers","NFL Expert Picks","Norm Elrod","sports","NFL Week 11 AFC West Picks: 'No Chance That The Jets Get A Win Against The Chargers,' Says CBS LA's Jaime Maggio"],"datePublished":"2020-11-19T15:12:41+00:00","dateModified":"2020-11-19T15:12:41+00:00"}</script>
<script>cbs_lib.load_script("//launch.newsinc.com/js/embed.js");</script><script type="text/javascript">cbs_ads.partners.add("amazon", "3063");if(!window["apstag"]){window["apstag"]={init:function(){window["apstag"]._Q.push(["i",arguments]);},fetchBids:function(){window["apstag"]._Q.push(["f",arguments]);},setDisplayBids:function(){},_Q:[]};}</script>

<script type="text/javascript">cbs_ads.partners.add("sharethrough", true);</script>
<script>cbs_ads.init("4128","CBS.STL","sports",["nflweek11afcwestpicksnochancethatthejetsgetawinagainstthechargerssayscbslasjaimemaggio","post","article","sports","afcwest","denverbroncos","jaimemaggio","kansascitychiefs","lasvegasraiders","losangeleschargers","nflexpertpicks","normelrod","featuredvideo"],{"page_type":"article"});cbs_ads.refresh.set_timer("1");</script>
		<style type="text/css" id="wp-custom-css">
			.single-post sup {
	vertical-align: super;
	font-size: 10px;
}		</style>
		<!-- WP Header - End -->

	<meta name="description" content="CBS Los Angeles sports anchor Jaime Maggio looks at AFC West matchups, as the Chargers look to down the Jets, and the Chiefs seek to avenge their loss to the Raiders." />
<script>//<![CDATA[
		window['_cmpWrapper'] = {
			loaded: function(callback) { cbsoptanon.cmd.push(function(cmp) { cmp.ot.getState(callback); }); },
			getConsentFlag: function(callback) {
				window._cmpWrapper.loaded(function(tar, per, fun, soc) {
					var consent = 0; var consentState = [ per, fun, tar, soc, false ];
					for (var i = 0; i < consentState.length; i++) { if (consentState[i]) { var mask = 1 << i; consent |= mask; } }
					callback(consent);
				});
			}
		}
		//]]></script>

</head>

<body class="post-template-default single single-post postid-596094 single-format-standard desktop-display-type  and-temp-wide"><div id="wrapper" class="body-wrapper">

<div id="reptile_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin" data-ad_location="skin"><script>cbs_load_skin_by_tile(1);</script></div><header id="page-header" class=""><div class="wrapper">

				<a href="https://stlouis.cbslocal.com" id="header-logo"><img src="https://stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2018/07/2_cbs_stlouis.png?w=216" alt="CBS St. Louis" /></a>
	
	<nav id="navigation-main" data-item-count="6"><ul class="top"><li class="menu-top-item item-0 section-item"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Menu</strong></div></div></li><li class="menu-top-item item-1 w-link w-submenu"><a href="http://stlouis.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">News</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">All News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://stlouis.cbslocal.com/category/news/" title="Latest News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest News</strong></div></a><a href="http://stlouis.cbslocal.com/category/health/" title="HealthWatch" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">HealthWatch</strong></div></a><a href="http://stlouis.cbslocal.com/category/travel/" title="Travel" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Travel</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-5 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Latest News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://stlouis.cbslocal.com/2020/11/19/how-to-cook-turkey-jennie-o-thanksgiving-tips/" title="How To Cook A Turkey To Perfection: Jennie-O Provides Crucial Thanksgiving Dinner Tips" class="cbs-thumbnail-link item-1605820496" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">How To Cook A Turkey To Perfection: Jennie-O Provides Crucial Thanksgiving Dinner Tips</strong><em class="description">Thanksgiving is right around the corner. Here are some tips if you plan to make a Turkey Day feast for the first time.</em></div></a><a href="https://stlouis.cbslocal.com/2020/11/19/toilet-paper-shortage-covid-panic-buying/" title="Can&#039;t Spare A Square: Toilet Paper Shortage Fears Lead To More &#039;Panic Buying&#039; In Parts Of Country" class="cbs-thumbnail-link item-1605801955" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://stlouis.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2020/11/toilet-paper-costco-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Can&#039;t Spare A Square: Toilet Paper Shortage Fears Lead To More &#039;Panic Buying&#039; In Parts Of Country</strong><em class="description">With COVID-19 cases rising, shortages of toilet paper, paper towels and cleaning supplies are returning in many parts of the country as well.</em></div></a><a href="https://stlouis.cbslocal.com/2020/11/17/stimulus-package-covid-update-aid-relief-mitch-mcconnell-nancy-pelosi-negotiations/" title="Stimulus Package Update: Politicians Still Can&#039;t Agree On Type Of Aid Or How Much To Spend" class="cbs-thumbnail-link item-1605641803" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://stlouis.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2020/11/us-capitol-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Stimulus Package Update: Politicians Still Can&#039;t Agree On Type Of Aid Or How Much To Spend</strong><em class="description">Democrats and Republicans agree on the need for a stimulus package, but disagree on specifics like stimulus checks and and the overall cost.</em></div></a><a href="https://stlouis.cbslocal.com/2020/11/13/second-stimulus-package-update-covid-joe-biden-mitch-mcconnell/" title="Stimulus Package Update: What Will A Biden Administration Mean For More Aid?" class="cbs-thumbnail-link item-1605289729" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://stlouis.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2020/11/joe-biden-1-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Stimulus Package Update: What Will A Biden Administration Mean For More Aid?</strong><em class="description">Containing the COVID-19 pandemic and rebuilding the economy top the list for the incoming Biden  administration, and a stimulus package will be a key component.</em></div></a><a href="https://stlouis.cbslocal.com/2020/11/09/100-missions-surviving-vietnam-dr-michael-hankins/" title="&#039;The Goal Is To Put An Individual Face To These Combat Pilots&#039;: Dr. Michael Hankins On Smithsonian Channel Special &#039;100 Missions: Surviving Vietnam&#039;" class="cbs-thumbnail-link item-1604950073" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://stlouis.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2020/11/002_05_Bob-Dorrough-e1604946569871.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">&#039;The Goal Is To Put An Individual Face To These Combat Pilots&#039;: Dr. Michael Hankins On Smithsonian Channel Special &#039;100 Missions: Surviving Vietnam&#039;</strong><em class="description">It&#039;s been almost 50 years since the Vietnam War ended and a new special from the Smithsonian Channel dives into the U.S. Air Force pilots that flew in combat missions during the war.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-2 w-link w-submenu"><a href="http://stlouis.cbslocal.com/category/sports/" title="Sports" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Sports</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">All Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://stlouis.cbslocal.com/category/sports/" title="Latest" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest</strong></div></a><a href="http://www.cbssports.com/golf/" title="PGA" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">PGA</strong></div></a><a href="http://www.cbssports.com/nfl/" title="NFL" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">NFL</strong></div></a><a href="http://www.cbssports.com/mlb/" title="MLB" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">MLB</strong></div></a><a href="http://www.cbssports.com/nba/" title="NBA" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">NBA</strong></div></a><a href="http://www.cbssports.com/nhl/" title="NHL" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">NHL</strong></div></a><a href="http://www.sportsline.com/" title="Odds" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">Odds</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-4 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Latest Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://stlouis.cbslocal.com/2020/11/19/nfl-week-11-afc-west-picks-chargers-broncos-chiefs-raiders/" title="NFL Week 11 AFC West Picks: &#039;No Chance That The Jets Get A Win Against The Chargers,&#039; Says CBS LA&#039;s Jaime Maggio" class="cbs-thumbnail-link item-1605820361" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://stlouis.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2020/11/justin-herbert-chargers-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">NFL Week 11 AFC West Picks: &#039;No Chance That The Jets Get A Win Against The Chargers,&#039; Says CBS LA&#039;s Jaime Maggio</strong><em class="description">CBS Los Angeles sports anchor Jaime Maggio looks at AFC West matchups, as the Chargers look to down the Jets, and the Chiefs seek to avenge their loss to the Raiders.</em></div></a><a href="https://stlouis.cbslocal.com/2020/11/19/fantasy-football-start-sit-week-11-mike-davis/" title="Fantasy Football Start Or Sit Week 11: Mike Davis Has A &quot;Dream&quot; Matchup Against Lions Defense" class="cbs-thumbnail-link item-1605816614" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://stlouis.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2020/11/GettyImages-1285832077.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Fantasy Football Start Or Sit Week 11: Mike Davis Has A &quot;Dream&quot; Matchup Against Lions Defense</strong><em class="description">The Panthers back hasn&#039;t been overly effective in the last few weeks but he gets a great opportunity on Sunday going against a Lions D that has allowed the most fantasy points to opposing backs this season.</em></div></a><a href="https://stlouis.cbslocal.com/2020/11/19/nfl-week-11-afc-north-picks-steelers-ravens-browns-bengals/" title="NFL Week 11 AFC North Picks: Are The Steelers Looking Past The Jaguars?" class="cbs-thumbnail-link item-1605801019" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://stlouis.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2020/11/ben-roethlisberger-steelers-1-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">NFL Week 11 AFC North Picks: Are The Steelers Looking Past The Jaguars?</strong><em class="description">With the Steelers, Ravens and Browns, the AFC North has three potential playoff contenders going into Week 11.</em></div></a><a href="https://stlouis.cbslocal.com/2020/11/17/fantasy-football-waiver-wire-week-11-salvon-ahmed/" title="Fantasy Football Waiver Wire Week 11: Salvon Ahmed Stepping Into Spotlight For Dolphins" class="cbs-thumbnail-link item-1605623894" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://stlouis.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2020/11/GettyImages-1285851581.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Fantasy Football Waiver Wire Week 11: Salvon Ahmed Stepping Into Spotlight For Dolphins</strong><em class="description">The undrafted rookie appears to have taken over the starting back role in Miami with Myles Gaskin on IR.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-3 w-link"><a href="http://stlouis.cbslocal.com/live/" title="Video" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Video</strong></div></a></li><li class="menu-top-item item-4 w-link w-submenu"><a href="http://stlouis.cbslocal.com/category/top-spots/" title="Top Spots" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Top Spots</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-6 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://stlouis.cbslocal.com/category/top-spots">Latest Headlines</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://stlouis.cbslocal.com/2018/06/11/stephen-king-amazon-alexa-google-assistant/" title="&quot;Stephen King Library&quot; Coming To A Smart Speaker Near You" class="cbs-thumbnail-link item-1528738579" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://stlouis.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2018/06/sk2.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">&quot;Stephen King Library&quot; Coming To A Smart Speaker Near You</strong></div></a><a href="https://stlouis.cbslocal.com/2018/05/25/best-beach-vacations-atlantic/" title="Best Beach Vacations On The Atlantic" class="cbs-thumbnail-link item-1527262085" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://stlouis.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2018/05/3167f6cfb00940918b82e31bd524b67f.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Best Beach Vacations On The Atlantic</strong><em class="description">A look at five of the best beach vacations with widest range of things to do and places to stay along the Atlantic Coast.</em></div></a><a href="https://stlouis.cbslocal.com/2018/05/02/treat-mom-to-a-bb-fit-for-a-queen/" title="Treat Mom To A B&amp;B Fit For A Queen" class="cbs-thumbnail-link item-1525282846" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://stlouis.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2018/05/52c92ba6f34445fb9da6d01ec72a785a.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Treat Mom To A B&amp;B Fit For A Queen</strong><em class="description">Treat your mother to a B&amp;B fit for a queen this Mother&#039;s Day.</em></div></a><a href="https://stlouis.cbslocal.com/2018/04/25/explore-americas-castles/" title="Explore America&#039;s Castles" class="cbs-thumbnail-link item-1524691241" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://stlouis.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2018/04/biltmore.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Explore America&#039;s Castles</strong><em class="description">These are five of the finest castles in America to explore for that next big vacation.</em></div></a><a href="https://stlouis.cbslocal.com/2018/04/18/best-art-museums-in-the-southwest/" title="Best Art Museums In The Southwest" class="cbs-thumbnail-link item-1524071216" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://stlouis.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2018/04/museum-feature.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Best Art Museums In The Southwest</strong><em class="description">Many of America&#039;s best art museums can be found in the American Southwest.</em></div></a><a href="https://stlouis.cbslocal.com/2018/02/13/best-ways-to-support-st-louis-local-art-scene/" title="Best Ways To Support St. Louis&#039; Local Art Scene" class="cbs-thumbnail-link item-1518534000 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://stlouis.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2017/11/gettyimages-608888206-e1518537576532.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Best Ways To Support St. Louis&#039; Local Art Scene</strong><em class="description">Artists. They come in all shapes, sizes, and are interested in a myriad of mediums and genres. They think, emote and imagine. They make the world a better place by adorning it with their artistic visions. They are forceful and passionate about their craft. And they live and for the community that spurs their creativity. In St. Louis we love our artists and we love the organizations that support and encourage them. Check out these great artist support systems and maybe join in the fun by partaking in some classes, shopping and creating.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-5 w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">More</strong></div></div><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-5 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://stlouis.cbslocal.com/category/travel/">Travel</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://stlouis.cbslocal.com/2019/08/30/8-reasons-to-visit-istanbul-turkey/" title="8 Reasons to Visit Istanbul, Turkey" class="cbs-thumbnail-link item-1567188772 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://stlouis.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2019/08/GettyImages-1024871980.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">8 Reasons to Visit Istanbul, Turkey</strong></div></a><a href="https://stlouis.cbslocal.com/2019/08/22/nfl-stadium-guides-parking-transportation-tailgating/" title="Heading To An NFL Game? Be Sure To Check Out Our NFL Stadium Guides" class="cbs-thumbnail-link item-1566480885" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://stlouis.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2019/08/GettyImages-466663843.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Heading To An NFL Game? Be Sure To Check Out Our NFL Stadium Guides</strong><em class="description">If you and your family are headed to an NFL game this season, we have you covered with guides to stadiums across the league.</em></div></a><a href="https://stlouis.cbslocal.com/2019/06/13/top-3-eco-friendly-vacation-spots/" title="Top 3 Eco-Friendly Vacation Spots" class="cbs-thumbnail-link item-1560449704" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://stlouis.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2019/06/gettyimages-598645380-e1537896793352.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Top 3 Eco-Friendly Vacation Spots</strong><em class="description">Check out the three best spots for an eco-friendly vacation!</em></div></a><a href="https://stlouis.cbslocal.com/2019/04/04/final-four-guide-top-10-instagram-worthy-spots-in-minneapolis/" title="Final Four Guide: Top 10 Most Instagram-Worthy Spots In Downtown Minneapolis" class="cbs-thumbnail-link item-1554411634" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://stlouis.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2019/04/igworthy.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final Four Guide: Top 10 Most Instagram-Worthy Spots In Downtown Minneapolis</strong><em class="description">With thousands of Final Four fans heading to downtown Minneapolis in the coming days, you better believe the Instagram filters will be flying.</em></div></a><a href="https://stlouis.cbslocal.com/2019/04/04/final-four-guide-best-breweries-minneapolis/" title="Final Four Guide: Best Breweries To Visit While You&#039;re In Minneapolis" class="cbs-thumbnail-link item-1554411465" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://stlouis.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2019/04/187774436.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final Four Guide: Best Breweries To Visit While You&#039;re In Minneapolis</strong><em class="description">Beer-lovers visiting Minneapolis for the Final Four won’t have to go far to find Minnesota’s most beloved beers. Walk in any direction out of U.S. Bank Stadium and you’ll probably find a bar or restaurant serving craft beers from the Twin Cities, the North Shore and other parts of “The Land of 10,000 Beers.&quot; But for hop heads seeking a more direct experience of the state’s brewing culture, there are a few places that need to be on your radar, because they’re well worth the Lyft ride.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">More</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://stlouis.cbslocal.com/category/only-cbs/" title="CBS Entertainment" class="cbs-thumbnail-link item-1519667649" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://stlouis.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2018/02/only-cbs-124x75.jpg?w=124&#038;h=75&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">CBS Entertainment</strong></div></a>		</div>
	</section>
</div></div></li></ul></nav>
	
	
	<div id="info-search"><form action="https://stlouis.cbslocal.com/search/" class="form"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search..." /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="&#xf002" /></form><span class="open-close" onclick="jQuery(document).ready(function(){jQuery('#info-search').toggleClass('open');});"></span></div>
</div></header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div id="reptile_1_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_1"><div id="reptile_1" class="ad-block" data-ad_size="[[970,250],[970,66],[728,90]]" data-ad_location="top"><script>cbs_load_ad_by_tile("1");</script></div></span></div>		</section>
		
<div id="page-content" class="main-white page-block-container and-w-sidebar">
<header id="page-rubric" class="">

			<div class="banner-title-wrapper">
							<h1 class="title">NFL Week 11 AFC West Picks: &#8216;No Chance That The Jets Get A Win Against The Chargers,&#8217; Says CBS LA&#8217;s Jaime Maggio</h1>
					</div>
	
	
	
	
	
</header>
<section class="page-columns"><section class="page-column three-column" id="article-entry-date-and-tags"><div class="column-header"><time class="post-date">November 19, 2020 at 3:12 pm</time><div class="column-header-metadata"><strong>Filed Under:</strong><span><a href="https://stlouis.cbslocal.com/tag/afc-west/">AFC West</a>, <a href="https://stlouis.cbslocal.com/tag/denver-broncos/">Denver Broncos</a>, <a href="https://stlouis.cbslocal.com/tag/jaime-maggio/">Jaime Maggio</a>, <a href="https://stlouis.cbslocal.com/tag/kansas-city-chiefs/">Kansas City Chiefs</a>, <a href="https://stlouis.cbslocal.com/tag/las-vegas-raiders/">Las Vegas Raiders</a>, <a href="https://stlouis.cbslocal.com/tag/los-angeles-chargers/">Los Angeles Chargers</a>, <a href="https://stlouis.cbslocal.com/tag/nfl-expert-picks/">NFL Expert Picks</a>, <a href="https://stlouis.cbslocal.com/tag/norm-elrod/">Norm Elrod</a></div></div></section><section id="column_block_1" class="page-column and-content-column two-column"><div class="column-item story" id="main-story"><section class="column-item media-type-anvato  ratio-display close-btn" id="featured-media"><div id="floating-player-container" class="video-wrapper anvato"><div id="p0"></div><script>cbsoptanon.onScriptsReady(function(cmp){cmp.ot.targetingAllowed(function(a){if(a) AnvatoPlayer("p0").init({"mcp":"cbs","width":"100%","height":"100%","video":"4886399","autoplay":true,"titleVisible":false,"accessKey":"5VD6Eyd6djewbCmNwBFnsJj17YAvGRwl","accessControl":{"preview":false},"pInstance":"p0","plugins":{"heartbeat":{"account":"cbslocal-global-unified","publisherId":"cbslocal","jobId":"sc_va","marketingCloudId":"823BA0335567497F7F000101@AdobeOrg","trackingServer":"cbsdigitalmedia.hb.omtrdc.net","customTrackingServer":"cbsdigitalmedia.d1.sc.omtrdc.net","chapterTracking":false,"version":"1.5"},"comscore":{"clientId":"3000023","c3":"StLouis.cbslocal.com"},"dfp":{"clientSide":{"adTagUrl":"http:\/\/pubads.g.doubleclick.net\/gampad\/ads?sz=2x2&iu=\/4128\/CBS.STL&ciu_szs&impl=s&gdfp_req=1&env=vp&output=xml_vast2&unviewed_position_start=1&url=[referrer_url]&description_url=[description_url]&correlator=[timestamp]","keyValues":{"categories":"[[CATEGORIES]]","program":"[[PROGRAM_NAME]]","siteSection":"featured"}}}},"shareLink":"https:\/\/cbsloc.al\/2UKd5Au","video-type":"featured","token":"default","expectPreroll":true,"expectPrerollTimeout":5});});});</script></div></section>
<div class="main-story-wrapper"><p><strong>(<a href="https://losangeles.cbslocal.com/2020/11/19/nfl-week-11-afc-west-picks-chargers-broncos-chiefs-raiders/">CBS Los Angeles</a>) &#8212;</strong> The Kansas City Chiefs still have the inside track on the AFC West title. But there could very well be some bumps in the road. Their remaining schedule features a few tough matchups, not to mention rematches with each of their three division rivals. That starts this Sunday with the Las Vegas Raiders, the only team to beat them so far. The Raiders, at 6-3, are coming off a thrashing of the Denver Broncos, and will be looking to stay in the mix of what&#8217;s become a very competitive AFC playoff race. Six teams hold a 6-3 record in the AFC, but only one of them leads their division.</p>
<p>The Broncos host the resurgent Dolphins, one of those 6-3 playoff contenders behind rookie quarterback Tua Tagovailoa. Miami is riding a five-game winning streak, the Broncos have lost two straight. Their last win came against the Los Angeles Chargers on a last-second touchdown catch. That was the first of three straight Chargers losses. But they draw a favorable matchup in Week 11, with the winless New York Jets flying in.</p>
<p>CBS Los Angeles sports anchor Jaime Maggio looks at this week&#8217;s matchups in the AFC West.</p>
<p><em>All times listed are Eastern.</em></p>
<p><strong>New York Jets @ Los Angeles Chargers, Sunday, November 22, 4:05 p.m. (CBS)</strong></p>
<p>The Chargers probably aren&#8217;t as bad as their 2-7 record suggests. They&#8217;ve lost some close games to some good teams. The Chiefs and the New Orleans Saints both needed overtime to get past the Chargers. &#8220;Of those seven losses, six have been by seven points or fewer,&#8221; as Maggio points out. &#8220;And actually the greatest margin was last week, which was eight points, and that was against the Miami Dolphins.&#8221;</p>
<p>Rookie quarterback Justin Herbert is putting up Rookie of the Year-type numbers so far, with 19 TD passes against just six interceptions. He&#8217;s averaging 291.6 yards per game, with rating of 102.8. &#8220;I think that they have a very talented quarterback in Justin Herbert, having a heck of a rookie campaign,&#8221; says Maggio. &#8220;They&#8217;ve seen a lot of positive stuff from him.&#8221;</p>
<p><em><strong>&gt;&gt;READ: <a href="/2020/11/19/fantasy-football-start-sit-week-11-mike-davis/" rel="nofollow">Fantasy Football Start Or Sit Week 11: Mike Davis Has A &ldquo;Dream&rdquo; Matchup Against Lions Defense</a></strong></em></p>
<p>The Jets, on the other hand, haven&#8217;t seen much of anything positive from anyone. Their defense ranks near the bottom in yards and points allowed per game. Their offense ranks dead last in yards and points per game. On the offensive side, maybe some of that can be blamed on Sam Darnold&#8217;s lingering shoulder injury. And, indeed, backup quarterback Joe Flacco did almost lead the Jets to their first win of the season against the New England Patriots a couple weeks back.</p>
<p>Coming off the bye, Flacco will start again against the Chargers. The Jets also have some motivation to not go winless for an entire season, with this being their best chance at a victory. Maggio doesn&#8217;t think it will happen, however. &#8220;There is no chance that the Jets get a win against the Chargers this week,&#8221; she says. &#8220;This is an opportunity, I think, for the Chargers to go out there and have kind of a bully performance and get back on track. They are the fourth-ranked offense in the NFL. Justin Herbert, like I said, one heck of a rookie year. He has six consecutive games with multiple touchdown passes. I think that will continue.&#8221;</p>
<p><strong>Miami Dolphins @ Denver Broncos, Sunday, November 22, 4:05 p.m. (CBS)</strong></p>
<p>The Dolphins opened their season losing three of their first four games. They&#8217;ve since won five straight, three of them under the leadership of Tagovailoa. In those games, he&#8217;s thrown five touchdown passes, but only topped 200 yards passing once. The Dolphins may also lean on undrafted free agent running back Salvon Ahmed with lingering injuries hindering their backfield.</p>
<p>But it&#8217;s the Dolphins defense that could pose some problems for the Broncos. &#8220;They boast a defense that can really do damage to teams,&#8221; says Maggio. &#8220;And that&#8217;s a perfect matchup for their defense against this Broncos offense, which leads the league in picks and giveaways. And I&#8217;ll tell you why that&#8217;s important, because last year, they were one of the best teams at protecting the ball. They&#8217;ve actually regressed. This year they are one of the worst teams at protecting the ball. And I think you can attribute that directly to the fact that they have used three different quarterbacks in the last nine games.&#8221;</p>
<p><em><strong>&gt;&gt;READ: <a href="/2020/11/19/nfl-week-11-afc-north-picks-steelers-ravens-browns-bengals/" rel="nofollow">NFL Week 11 AFC North Picks: Are The Steelers Looking Past The Jaguars?</a></strong></em></p>
<p>Those three quarterbacks &#8212; Drew Lock, Jeff Driskel and Brett Rypien &#8212;&nbsp; have tossed a league-high 16 interceptions. The Broncos offense, unsurprisingly, has sputtered for much of the season, both in terms of yards and points. They rank near the bottom of the league in both categories. The defense isn&#8217;t all that much better.</p>
<p>Broncos starting quarterback Drew Lock is questionable this week with a rib injury, but it might no ultimately matter. The Dolphins are rolling. &#8220;This is going to be a feast for the Dolphins defense ahead of Thanksgiving,&#8221; says Maggio. &#8220;So I&#8217;m going to go with the Dolphins in this one.&#8221;</p>
<p><strong>Kansas City Chiefs @ Las Vegas Raiders, Sunday, November 22, 8:20 p.m. (NBC)</strong></p>
<p>The Chiefs come into this game as 6.5-point favorites over the Raiders, the only team to beat them this season. That first matchup, &#8220;&#8230;was like a coming-out party for the Las Vegas Raiders,&#8221; as Maggio puts it. &#8220;That was pretty something else. Derek Carr has an unbelievable outing in that Week 5 matchup&#8230; 347 yards, three touchdowns for him in that game.&#8221;</p>
<p>Another key component in that win was the running game. Josh Jacobs and Devontae Booker combined for 139 yards on the ground. &#8220;One of the weaknesses for the Chiefs is protecting against the run,&#8221; says Maggio. &#8220;And you&#8217;ve got Josh Jacobs and Devontae Booker, the two running backs for the Raiders, who are coming off big performances last week.&#8221;</p>
<p>The pair combined for almost 200 yards and four touchdowns, each averaging over five yards per carry in their runaway win over the Broncos.</p>
<p><em><strong>&gt;&gt;READ: <a href="/2020/11/17/fantasy-football-waiver-wire-week-11-salvon-ahmed/" rel="nofollow">Fantasy Football Waiver Wire Week 11: Salvon Ahmed Stepping Into Spotlight For Dolphins</a></strong></em></p>
<p>The Chiefs offense remains among the best in the NFL. They average a league-leading 294.7 passing yards per game and also put up 31.8 points per game. And they&#8217;ll be well-rested and well-prepared from a bye week.</p>
<p>For all the firepower that will be on display, this game could come down to defense. &#8220;What makes this matchup even more intriguing though is that practically the entire Raiders starting defense right now is on the COVID-19 list,&#8221; says Maggio. &#8220;They are on the list because of a high-risk exposure. If they continue to test negative throughout the week, then they&#8217;ll be eligible to play on Sunday. And this is a big Sunday-night matchup, so you know those guys are going to want to play.&#8221;</p>
<p>Clearly a severely short-handed Raiders defense would change the complexion of the game. As Maggio sees it, &#8220;if the defense is intact, we&#8217;re going to see a really close game. If not, I would have to go easily to the Chiefs. If everyone&#8217;s playing, if everyone&#8217;s at full strength, I&#8217;m going to say it&#8217;s close, and I say I give it to the Chiefs.&#8221;</p>
<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
				<span><a class="addthis_button_facebook"  addthis:url="https://cbsloc.al/2UKd5Au"></a><a class="addthis_button_twitter"  addthis:url="https://cbsloc.al/2UKd5Au"></a><a href="#" class="addthis_button_linkedin"></a><a href="#" class="addthis_button_reddit"></a><a class="addthis_button_compact"  addthis:url="https://cbsloc.al/2UKd5Au"></a></span>
			</div>
		
			</div>
</div></div></div><div id="reptile_30_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper partner-container partner-sharethrough"><span id="ad_30"><div id="reptile_30" class="ad-block" data-ad_size="[[1,5]]" data-ad_location="partner-injected" data-ad_targets={"strnativekey":"d3da4d50"}><script>cbs_load_ad_by_tile("30");</script></div></span></div><div class="partner-container partner-taboola"><div id="taboola-block-2"></div></div></section><aside class="sidebar right-bar" rel="modular+"><div id="reptile_2_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_2"><div id="reptile_2" class="ad-block" data-ad_size="[[300,250],[300,600],[300,1050]]" data-ad_location="top"><script>cbs_load_ad_by_tile("2");</script></div></span></div><div id="" class="block sidebar-widget widget_cbs_follow_us_widget"><h3 class="title">Follow Us</h3>
		<div class="widget-content-wrapper">
					</div>

		</div><div id="" class="block sidebar-widget widget_top-posts"><h3 class="title"><span>Most </span> Viewed</h3><ul class='widgets-list-layout no-grav'>
					<li>
						<a href="https://stlouis.cbslocal.com/2019/04/04/final-four-guide-best-breweries-minneapolis/" title="Final Four Guide: Best Breweries To Visit While You&#039;re In Minneapolis" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2019/04/187774436.jpg?resize=55%2C55&#038;ssl=1" alt="Final Four Guide: Best Breweries To Visit While You&#039;re In Minneapolis" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://stlouis.cbslocal.com/2019/04/04/final-four-guide-best-breweries-minneapolis/" title="Final Four Guide: Best Breweries To Visit While You&#039;re In Minneapolis" class="bump-view" data-bump-view="tp">Final Four Guide: Best Breweries To Visit While You&#039;re In Minneapolis</a>
							</div>
													</li>
										<li>
						<a href="https://stlouis.cbslocal.com/2020/11/19/jersey-shore-family-vacation-mtv-interview/" title="Jenni Farley, Ronnie Ortiz-Magro, Deena Nicole Cortese, Pauly DelVecchio Preview Season 4 Of &#039;Jersey Shore Family Vacation&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2020/11/GettyImages-942097180-e1605802923768.jpg?resize=55%2C55&#038;ssl=1" alt="Jenni Farley, Ronnie Ortiz-Magro, Deena Nicole Cortese, Pauly DelVecchio Preview Season 4 Of &#039;Jersey Shore Family Vacation&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://stlouis.cbslocal.com/2020/11/19/jersey-shore-family-vacation-mtv-interview/" title="Jenni Farley, Ronnie Ortiz-Magro, Deena Nicole Cortese, Pauly DelVecchio Preview Season 4 Of &#039;Jersey Shore Family Vacation&#039;" class="bump-view" data-bump-view="tp">Jenni Farley, Ronnie Ortiz-Magro, Deena Nicole Cortese, Pauly DelVecchio Preview Season 4 Of &#039;Jersey Shore Family Vacation&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://stlouis.cbslocal.com/2020/10/30/auburn-lsu-aaron-murray-sec-on-cbs/" title="Aaron Murray On Auburn, LSU SEC West Clash On CBS: &#039;The Key For Bo Nix Is To Play Within Himself&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2020/10/GettyImages-1280794188.jpg?resize=55%2C55&#038;ssl=1" alt="Aaron Murray On Auburn, LSU SEC West Clash On CBS: &#039;The Key For Bo Nix Is To Play Within Himself&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://stlouis.cbslocal.com/2020/10/30/auburn-lsu-aaron-murray-sec-on-cbs/" title="Aaron Murray On Auburn, LSU SEC West Clash On CBS: &#039;The Key For Bo Nix Is To Play Within Himself&#039;" class="bump-view" data-bump-view="tp">Aaron Murray On Auburn, LSU SEC West Clash On CBS: &#039;The Key For Bo Nix Is To Play Within Himself&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://stlouis.cbslocal.com/2020/11/04/sally-hubbard-monopolies-suck-amazon-facebook-apple/" title="&#039;We Are Really At A Crisis Point For Our Democracy, Economy&#039;: Sally Hubbard On Big Tech Corporations &amp; Book &#039;Monopolies Suck&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2020/11/GettyImages-101625074-e1604513017495.jpg?resize=55%2C55&#038;ssl=1" alt="&#039;We Are Really At A Crisis Point For Our Democracy, Economy&#039;: Sally Hubbard On Big Tech Corporations &amp; Book &#039;Monopolies Suck&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://stlouis.cbslocal.com/2020/11/04/sally-hubbard-monopolies-suck-amazon-facebook-apple/" title="&#039;We Are Really At A Crisis Point For Our Democracy, Economy&#039;: Sally Hubbard On Big Tech Corporations &amp; Book &#039;Monopolies Suck&#039;" class="bump-view" data-bump-view="tp">&#039;We Are Really At A Crisis Point For Our Democracy, Economy&#039;: Sally Hubbard On Big Tech Corporations &amp; Book &#039;Monopolies Suck&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://stlouis.cbslocal.com/2020/11/06/fantasy-football-start-sit-week-9-chase-edmonds-j-k-dobbins/" title="Fantasy Football Start Or Sit Week 9: Chase Edmonds, J.K. Dobbins In Line For Bigger Workloads This Week" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2020/11/GettyImages-1282546753.jpg?resize=55%2C55&#038;ssl=1" alt="Fantasy Football Start Or Sit Week 9: Chase Edmonds, J.K. Dobbins In Line For Bigger Workloads This Week" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://stlouis.cbslocal.com/2020/11/06/fantasy-football-start-sit-week-9-chase-edmonds-j-k-dobbins/" title="Fantasy Football Start Or Sit Week 9: Chase Edmonds, J.K. Dobbins In Line For Bigger Workloads This Week" class="bump-view" data-bump-view="tp">Fantasy Football Start Or Sit Week 9: Chase Edmonds, J.K. Dobbins In Line For Bigger Workloads This Week</a>
							</div>
													</li>
										<li>
						<a href="https://stlouis.cbslocal.com/2020/11/11/masters-preview-tiger-woods-bryson-dechambeau-augusta/" title="Masters Preview: &#039;Things Are Just More Difficult For Tiger,&#039; Says Nick Faldo" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2020/11/tiger-woods-masters-1.jpg?resize=55%2C55&#038;ssl=1" alt="Masters Preview: &#039;Things Are Just More Difficult For Tiger,&#039; Says Nick Faldo" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://stlouis.cbslocal.com/2020/11/11/masters-preview-tiger-woods-bryson-dechambeau-augusta/" title="Masters Preview: &#039;Things Are Just More Difficult For Tiger,&#039; Says Nick Faldo" class="bump-view" data-bump-view="tp">Masters Preview: &#039;Things Are Just More Difficult For Tiger,&#039; Says Nick Faldo</a>
							</div>
													</li>
										<li>
						<a href="https://stlouis.cbslocal.com/2020/11/03/laurie-segall-boogaloo-boys-michigan-home-guard-gretchen-whitmer/" title="&#039;I Worry About Civil Unrest&#039;: CBS News Correspondent Laurie Segall On 2020 Election &amp; Militia Groups" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2020/11/GettyImages-1229133299-e1604419372652.jpg?resize=55%2C55&#038;ssl=1" alt="&#039;I Worry About Civil Unrest&#039;: CBS News Correspondent Laurie Segall On 2020 Election &amp; Militia Groups" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://stlouis.cbslocal.com/2020/11/03/laurie-segall-boogaloo-boys-michigan-home-guard-gretchen-whitmer/" title="&#039;I Worry About Civil Unrest&#039;: CBS News Correspondent Laurie Segall On 2020 Election &amp; Militia Groups" class="bump-view" data-bump-view="tp">&#039;I Worry About Civil Unrest&#039;: CBS News Correspondent Laurie Segall On 2020 Election &amp; Militia Groups</a>
							</div>
													</li>
										<li>
						<a href="https://stlouis.cbslocal.com/2020/11/04/election-second-stimulus-package-donald-trump-joe-biden/" title="What Do Election Results Mean For A Second Stimulus Package?" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2020/11/election-day-1.jpg?resize=55%2C55&#038;ssl=1" alt="What Do Election Results Mean For A Second Stimulus Package?" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://stlouis.cbslocal.com/2020/11/04/election-second-stimulus-package-donald-trump-joe-biden/" title="What Do Election Results Mean For A Second Stimulus Package?" class="bump-view" data-bump-view="tp">What Do Election Results Mean For A Second Stimulus Package?</a>
							</div>
													</li>
										<li>
						<a href="https://stlouis.cbslocal.com/2018/05/02/treat-mom-to-a-bb-fit-for-a-queen/" title="Treat Mom To A B&amp;B Fit For A Queen" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2018/05/52c92ba6f34445fb9da6d01ec72a785a.jpg?resize=55%2C55&#038;ssl=1" alt="Treat Mom To A B&amp;B Fit For A Queen" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://stlouis.cbslocal.com/2018/05/02/treat-mom-to-a-bb-fit-for-a-queen/" title="Treat Mom To A B&amp;B Fit For A Queen" class="bump-view" data-bump-view="tp">Treat Mom To A B&amp;B Fit For A Queen</a>
							</div>
													</li>
										<li>
						<a href="https://stlouis.cbslocal.com/2020/11/17/stimulus-package-covid-update-aid-relief-mitch-mcconnell-nancy-pelosi-negotiations/" title="Stimulus Package Update: Politicians Still Can&#039;t Agree On Type Of Aid Or How Much To Spend" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2020/11/us-capitol-1.jpg?resize=55%2C55&#038;ssl=1" alt="Stimulus Package Update: Politicians Still Can&#039;t Agree On Type Of Aid Or How Much To Spend" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://stlouis.cbslocal.com/2020/11/17/stimulus-package-covid-update-aid-relief-mitch-mcconnell-nancy-pelosi-negotiations/" title="Stimulus Package Update: Politicians Still Can&#039;t Agree On Type Of Aid Or How Much To Spend" class="bump-view" data-bump-view="tp">Stimulus Package Update: Politicians Still Can&#039;t Agree On Type Of Aid Or How Much To Spend</a>
							</div>
													</li>
					</ul>
</div><div id="reptile_31_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper big-right-ad sidebar-adhesive-ad"><span id="ad_31"><div id="reptile_31" class="ad-block" data-ad_size="[[300,250]]" data-ad_location="adhesion"><script>cbs_load_ad_by_tile("31");</script></div></span></div></aside></section>		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div id="reptile_4_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_4"><div id="reptile_4" class="ad-block" data-ad_size="[[728,90]]" data-ad_location="bottom"><script>cbs_load_ad_by_tile("4");</script></div></span></div>		</section>
		

</div>


<footer id="page-footer" class="page-footer-type-menus-vertical">
			<section class="top"><div class="wrapper">
			<a href="https://stlouis.cbslocal.com" class="logo"><img src="https://stlouis.cbslocal.com/wp-content/uploads/sites/15909850/2017/10/stlouis.png" alt="CBS St. Louis" /></a>					</div></section>
	
			<section class="middle"><div class="wrapper">
			
<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-0" >
		<header class="column-header">
				<h4 class="title">News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://stlouis.cbslocal.com/category/news/" title="Latest News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest News</strong></div></a><a href="/category/health/" title="HealthWatch" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">HealthWatch</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-1" >
		<header class="column-header">
				<h4 class="title">Other</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://stlouis.cbslocal.com/category/top-spots/" title="Top Spots" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Top Spots</strong></div></a><a href="https://stlouis.cbslocal.com/category/travel/" title="Travel" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Travel</strong></div></a><a href="https://stlouis.cbslocal.com/category/health/" title="Health" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Health</strong></div></a><a href="https://stlouis.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-2" >
		<header class="column-header">
				<h4 class="title">Corporate</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://stlouis.cbslocal.com/site-info/" title="Contact" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Contact</strong></div></a>		</div>
	</section>
		</div></section>
	
			<section class="bottom"><div class="wrapper">
			<a href="https://stlouis.cbslocal.com" class="logo"><img src="https://stlouis.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/theme-manager/images/cbs-local-logo-white.png" alt="CBS St. Louis" /></a>
			<div class="copyright-wrapper">
				<span class="copyright">&copy;2020 CBS Broadcasting Inc. All Rights Reserved.</span>
									<span class="powered-by-wordpress">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=stlouis.cbslocal.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a></span>
							</div>

			<div class="right-wrapper">
									<div class="terms-of-use">By viewing our video content, you are accepting the terms of our <a href="https://privacy.cbs/videoservices" target="_blank" title="Video Services Policy">Video Services Policy</a></div>
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-202325" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-202325"><a href="https://privacy.cbs/">Privacy Policy</a></li>
<li id="menu-item-202327" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-202327"><a href="http://policies.cbslocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-591804" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-591804"><a href="https://ca.privacy.cbs">California Privacy/Info We Collect</a></li>
<li id="menu-item-591805" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-591805"><a href="https://ca.privacy.cbs/donotsell">Do Not Sell My Personal Information</a></li>
<li id="menu-item-439176" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-439176"><a href="http://policies.cbslocal.com/mobile-app-agreement/">Mobile User Agreement</a></li>
</ul>			</div>

						</div></section>
</footer>

<!--PARTNER SCRIPTS START-->
<div id="reptile_32_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_32"><div id="reptile_32" class="ad-block" data-ad_size="[[1,8]]" data-ad_location=""><script>cbs_load_ad_by_tile("32");</script></div></span></div><div id="reptile_33_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_33"><div id="reptile_33" class="ad-block" data-ad_size="[[1,6]]" data-ad_location=""><script>cbs_load_ad_by_tile("33");</script></div></span></div><div id="reptile_34_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_34"><div id="reptile_34" class="ad-block" data-ad_size="[[1,7]]" data-ad_location=""><script>cbs_load_ad_by_tile("34");</script></div></span></div>
<!--PARTNER SCRIPTS END-->


</div>

<!-- Instagram Feed JS -->
<script type="text/javascript">
var sbiajaxurl = "https://stlouis.cbslocal.com/wp-admin/admin-ajax.php";
</script>
<link rel='stylesheet' id='all-css-0' href='https://stlouis.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/partners/css/partners.css?m=1563315922g' type='text/css' media='all' />
<script type='text/javascript' src='https://stlouis.cbslocal.com/wp-includes/js/wp-embed.min.js?m=1604003351g'></script>
<script src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js?ver=5.5.2' id='cbs-cbs-anvato-js'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202047.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.1',blog:'162246020',post:'596094',tz:'-6',srv:'stlouis.cbslocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '162246020', '596094' ]);
</script>



<script type="text/javascript">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</script>

	
	
	
	
</body>
</html>